Seiko Data-2000 New watch battery lasts about a day

I recently acquired a Data-2000. The person I bought it from said that he had replaced the batteries and it was working great. When the watch arrived at my place I found it to be not working, as in it looked like it was dead. We came to the conclusion that the battery he put in must of been mistakenly an older battery. So I took it to the shop and they replaced the battery and it came to life! Joy! fast forward a day and a half, I get up in the morning to find that it's dead again!! What is going on here? Now I'm thinking that the person I bought this from really did put new batteries in it and it died in the mail as it was coming to me. Anybody experience this before, or how I might be able to fix it?

Thank you

Original Post

Sometimes extreme cold sucks battery power ridiculously quick so that could have explained the charge being lost in the mail (Pun intended).

However, unless you keep it in the freezer at home my reply is essentially just a waste of your time! 

Actually come to think of it, a few of my watches tend to die every now and again but it's not because of the battery, I think it's just a loose connection or dodgy module. It's a bugger but I just have to pop the back and reset the module every now and then :/

 

Thank you for the reply! I didn't think anybody was going to. I have an update on this. It's not the battery. Here's what's happening.. I took it back to the shop I had the battery changed and asked them about the problem. He took it into the back and came out with a working watch. Great! I asked him what he did and he said that he just reset the circuit. Ok, cool. I went home put it in my desk, woke up the next morning, an the screen was blank again! So strange! I took the back off and tried the reset myself, it worked again. But the screen keeps going dead after a few hours after everytime. The last time I tried it stayed on for like one minute, then died. 

Dose this maybe help you diagnose the problem? When the watch is on it looks perfect. This must be something that can be fixed. 

Thank you, again for your help.

Coincidentally I have just started to have the same problem with my CA-50. In my case though, I haven't actually ruled out the possibility of the battery actually being flat, but I don't think it is.

mine stops working after I've worn it for a bit though, it was working for a good year in my display case. This shows that there must be some interruption in the circuit when the watch is jostled around or a short circuit. Could've been water damaged at some time in its life or the module is just getting old. It is 36 years old after all!

I have a hunch about this one part in the module that I have adjusted which may fix it but only time will tell. Also, the display characters have started acting up in mine. At least I can replace the module in mine with a 3208, yours is probably not so simple (great watch by the way)

I will let you know if I've managed to fix it, in the meantime, if you could pop the back and post a picture of the module with the battery out I might spot something, but realistically, chances are slim.

Good luck!

Interesting. Sounds a lot like my problem, between this reply and the last my watch has come to life and died again 3 times. Twice I took the back off to reset the circuit, once it just happened by itself while I was wearing it. This supports your "something being jostled" theory, sometimes pushing the buttons made the watch die. Although, more than once, it died while just on my desk. 

I tried to take the battery out, it's hard, I cant quite figure it out without feeling like I'm roughing it up. Is there a special way to do it?

Thanks. Yeah, I think it would be hard and pricy to replace mine. I just seems like it wants to work so bad, I just can't give up on it. Thanks for the support.

So update on mine then:

Judging from the last 30 ish hours, my watch has never worked better! After the initial intermittent display character problem for the first minute or so, it has been spot on for the longest period of time so far. All I did was bend a little leaf spring on the back of the module towards the backing plate. I'll upload a picture to show you what I mean, hold on.

So i bent this little tab upwards:

Thinking was that it must be there to make contact with the backing and if it got bent back by creep over 36 years it might mean that with a slight bump, it briefly loses contact.

I seem to vaguely remember reading that when you reset the module there is a time limit for replacing the back so that would explain it!

Now this doesn't mean that it will fix your particular watch but if this has in fact fixed my watch there is a good chance yours will have the same result!

I will update if the watch dies again and will try the fix on my other watches with this problem.

Fingers crossed and good luck!

 

so after removing the back to take that picture it has started to play up again. hopefully that's because of the contact being broken 

I'll reset it again and see how long it lasts.

Also, the way the battery comes out of mine is by levering a little metal tab from a metal strip across the battery, like so:

Nice Pics! I love that watch. How is it doing today?

Mine hasn't worked at all. I tried your suggestion. There are actually two of those metal "tabs" but I seemed to have the same results. The other photo is when it suddenly sprang to life yesterday afternoon and lasted about 2 hours. So frustrating! I mean, it looks great when it works, and it seems like it's something small that's keeping it from doing so. I have to decide on wether or not I'm going to return this and I can't decide. On one hand, it seems reasonable that it'll work, on the other.. it's not working, and what good is it if it doesn't work? A cool bracelet

 

Attachments

Photos (2)

Mine is still going strong, it's a shame yours is still having issues.

Did you bend up the tabs on the side of the strip? are you sure they are touching the backing when it's closed? If I were you I'd take the battery out and check all the contact points you can find. If there is some residue or anything it could be interrupting the circuit. Don't be afraid to take it apart, as long as you're careful you should have no trouble putting everything back in reverse order. It's less often the case with electronics, but I find when you take something apart, the solution becomes more obvious. DON'T lose any screws haha, I have done that  need to find a bolt for a casio CA-901!

How does the watch interface with the keyboard? could be something to do with those contact points?

other than that I'm not too sure what else to try, have you looked for any digital watch specialists or repair services?

There are some other members on here that seem to be way more knowledgeable than me. TIBER FLESERIU and OLD tom were talking about a seiko data 2000 although it was about a year ago. You might be able to get hold of them, or you could look for an operating manual in case that helps at all.

 

Good to hear!

I'm sure it's making good contact on the back plate. I have to push it down just a bit when I put the screws back in because the tabs are pushing on it, so, it's probably not that, unless I'm totally missing something. Thanks for the advice about taking it apart, it is kind of unnerving. I'll try it tonight, take pictures, and see if any of the connections are dirty. 

The keyboard works fine, when I can get the watch on it when it's working anyway. Either way, it should be able to function without the keyboard anyway. I did have one local jeweler look at it, he was the same who changed the battery. I'm not sure how experienced he was with digitals but he said that the connections looked good That's totally the thing though, I've called two other watch repair places and they both said that, no, they don't do digital watches and there's nothing they could do, to send it back to the manufacturer. Don't think I can but thank you, ha. Never thought about how hard it would be to find watch service, makes sense since not a lot of people wear watches anymore, let alone vintage digital form the 80s.

Thanks again, I'll report back  

Add Reply

Likes (0)
×
×
×
×